Microsoft Teams External Incoming/Outgoing Calling Issue

Incident Report for BSU Information Technology

Resolved

Inbound and outbound external calling service has been restored.

We apologize for any inconvenience caused by this brief outage.

Thank you,
Information Technology
Posted Jun 26, 2025 - 09:29 EDT

Investigating

Microsoft Teams phone service at BSU is currently restricted to internal (campus-to-campus) calls. External calls — both incoming and outgoing — are unavailable. On-campus (Teams to Teams) calling is unaffected.

The Information Technology (IT) Division is working to resolve the problem and restore the service as soon as possible. We will provide an update within 3 hours.

We apologize for any inconvenience and appreciate your patience. Please contact the IT Service Center with questions/concerns at ITSupport@bridgew.edu.
Posted Jun 26, 2025 - 09:16 EDT
This incident affected: Phone Service - External.