We are happy to inform you that Microsoft has restored service and department call queues should be functional again. For departments that utilize this feature, please confirm with your staff that they are able to activate their call queues and report any continuing issues to the IT Service Center at ITSupport@bridgew.edu or 508.531.2555.
The outage lasted approximately 3 hours.
Posted Feb 04, 2026 - 13:38 EST
Investigating
BSU is experiencing an issue with Microsoft Teams that is not allowing departments to activate their call queues on the web and desktop versions of the app. This issue does not impact direct calling to and from individual users, only department call queues. The Information Technology (IT) Division is working with Microsoft to resolve the problem and restore the service as soon as possible. We will provide an update within 3 hours.
We apologize for any inconvenience and appreciate your patience. Please contact the IT Service Center with questions/concerns at ITSupport@bridgew.edu or call 508.531.2555.
IT Service Center Division of Information Technology
Posted Feb 04, 2026 - 10:32 EST
This incident affected: Phone Service - External and Phone Service - Internal.