Phone Outage
Incident Report for BSU Information Technology
Resolved
Phone service has been restored.

We apologize for any inconvenience caused by this brief outage.

Please contact the IT Service Center at itsupport@bridgew.edu with any questions.

Thank you.
Posted Dec 05, 2023 - 08:57 EST
Investigating
The university is experiencing technical issues related to inbound and outbound phone calling. Information Technology is investigating the issue and working to restore access as quickly as possible. We will provide an update with more details and an estimated time for restoration when we have more information.

* Be advised that Microsoft Teams calling to other BSU numbers is not impacted by this outage; you can continue to send and receive phone calls through Teams to internal BSU numbers.

Thank you for your patience. Please email itsupport@bridgew.edu with questions.
Posted Dec 05, 2023 - 08:34 EST
This incident affected: Phone Service - External and Phone Service - Internal.