Demonstration Incident
Incident Report for BSU Information Technology
Resolved
This incident has been resolved.
Posted Oct 16, 2023 - 13:42 EDT
Investigating
This is an incident created for demonstration purposes only, there is nothing actually wrong (phew!)

Please contact the IT Service Center at itsupport@bridgew.edu or 508.531.2455 with questions or concerns.
Posted Oct 16, 2023 - 13:33 EDT
This incident affected: Department and Other Network Folders, Email / Outlook, ResNet Streaming, and Teams Communications.